DmN MuCMS - Server Environment Checker

You need PHP '.$required_php_version.' (or greater)'; } else{ $pass .='
  • You have PHP '.$required_php_version.' (or greater)
  • '; } foreach($extensions as $extension){ if(!extension_loaded($extension)){ $fail .= '
  • You are missing the '.$extension.' extension
  • '; } else{ $pass .= '
  • You have the '.$extension.' extension
  • '; } } if(version_compare(PHP_VERSION, '7.0', '>=')){ if(!extension_loaded("pdo_odbc") && !extension_loaded("pdo_sqlsrv")){ $fail .= '
  • You are missing all of the following extensions: pdo_odbc, pdo_sqlserv install atleast one of them
  • '; } } else{ if(!extension_loaded("pdo_odbc") && !extension_loaded("pdo_sqlsrv") && !extension_loaded("mssql")){ $fail .= '
  • You are missing all of the following extensions: pdo_odbc, pdo_sqlserv, mssql install atleast one of them
  • '; } } if(function_exists('ioncube_loader_iversion')){ $ilv = ioncube_loader_iversion(); $current_loader = sprintf("%d.%d.%d", $ilv / 10000, ($ilv / 100) % 100, $ilv % 100); if (version_compare($required_loader, $current_loader, ">")) { $fail .= '
  • Required IonCube loader '.$required_loader.' or later. Your IonCube loader version is '.$current_loader.'
  • '; } else{ $pass .= '
  • You have IonCube loader version '.$required_loader.' (or greater)
  • '; } } else{ $fail .= '
  • You are missing IonCube loaders.
  • '; } if($fail){ echo '

    Your server does not meet the following requirements in order to install DmN MuCMS.'; echo '
    The following requirements failed, please contact your hosting provider in order to receive assistance with meeting the system requirements for DmN MuCMS:'; echo '

    '; echo 'The following requirements were successfully met:'; echo ''; } else{ echo '

    Congratulations! Your server meets the requirements for DmN MuCMS.

    '; echo ''; } } ?>